개발자로 살아남기-캐나다

VS Code에서 터미널 노드 버전 바꾸기 nvm 본문

카테고리 없음

VS Code에서 터미널 노드 버전 바꾸기 nvm

志者必得 2021. 12. 28. 12:09

 

 

vscode를 오랫동안 사용해 오고 있었는데 최근에 버전업을 크게 하면서 node 16을 사용하고 있었습니다. 그런데 vscode 터미널만 열면 버전 8이 계속 나와서 nvm use 16을 터미널 열때 마다 치고 있었는데 더 이상은 안될것 같아서 바꿔 보려니 안되서 여러방법을 시도 해보던중에 찾게 되서 공유하고자 합니다.

 

일단 내 시스템에서 사용하고 있는 노드 버전을 한번 체크 해봅니다.

node -v

기본 값으로 사용하고 싶은 노드 버전이 있다면 아래와 같이 터미널에 입력하면 됩니다. 예를들어 16을 사용하고 싶다면 아래와 같이 입력하면 됩니다.

nvm alias default 16

 

vscode 터미널 버전이 다른 경우는 /usr/local/bin/node 에 노드 버전을 사용하고 있기 때문일 가능 성이 있습니다. nvm을 사용 하고 있다면 딱히 local node를 사용할 필요 가 없습니다.  저 같은 경우에는 아래와 같이 local을 지우고 vscode를 다시 실행하니 고쳐 졌습니다.

rm -rf /usr/local/bin/npm
rm -rf /usr/local/bin/node

 

보너스로 terminal에서 ITerm을 사용하고 싶다면 settings.json에 가서 아래와 같이 추가 해주시거나

  "terminal.external.osxExec": "iTerm.app",

설정에 가서 terminal을 검색 한 다음에 아래와 같이 바꿔 주시면 됩니다.

0 Comments
댓글쓰기 폼